NAS – Tinker Board

I know I have been away for a while. I have been busy studying for a exam at work. Done now.

In the meantime I have been messing around with some Tech toys. The unfortunate news that there was a vulnerability in Samba for Linux. Not good​ news. I use a Raspberry Pi for my main NAS. That has been updated as expected but  I use an old Zyxel NSA310 as a media server. There hasn’t been a firmware update for years so there is no chance of that getting patched.

Even though the chances of getting attacked are small, there is still a risk. So in the voice of Tom Hardy I looked at the Tinker Board and said.

The Tinker Board was already running Ubuntu server by Armbian. It was stable. It can see other devices on the network. I just plugged in a USB portable hard drive. Installed the latest Samba. I set up the network share via Webmin. Everything worked fine. My media plays perfectly over the network via Kodi on the Fire Stick. The old NSA310 was getting a bit wheezy with big video files.

I fancied trying Plex media server and that too installed and worked fine. I will put some tutorials up when I get chance.

Happily the Tinker Board has been up and running for days and it completely stable. The only problem is that the USB hard drive does not auto mount on reboot. I am sure there is a way to fix that.

Leave a Reply

Your email address will not be published. Required fields are marked *

12 − one =