Asus Tinker Board: The Second Test – Running Headless

Ok so now for another go on the ASUS Tinker Board!

Here it is in the new Pi case.

The last time I tried to run headless was a no go. Nothing happened, no activity on the lights, no appearance on the network, no SSH.
So this time I tried plugging into the Tinker Board a monitor, keyboard and mouse.

This time I was presented with scrolling list of commands as it booted up. Oh yes! It lives! Still nothing on the activity lights but I guess you can not have everything.

It booted into a rather vanilla looking desktop. It lacks the warm tailored view of the Raspberry PI PIXEL desktop. Only the basics are there, file manager, terminal windows and for a internet browser, Chromium.

The only problem was the internet or any network locations were missing. Even with the Ethernet plugged in, I still had to enable the Auto Ethernet option on the network connections before I could see anything else. This is the reason it would not connect to the network on my first headless attempt.

Once I found the board was connected to the network I confirmed SSH was open and signed in with Putty . The user name is ‘linaro’ and so is the password.

Sudo apt-get update
Sudo apt-get upgrade

This revealed a lot of updates that needed doing.

I still wanted to run the box headless. I could use it as a NAS or Minecraft server. While I could log in fine with SSH, I also wanted to test a VNC server and see the desktop that way. I followed some old Pi instructions.

So taking the monitor, keyboard and mouse away I could still use SSH. The using

Sudo apt-get install xorg tightvncserver

IĀ installed the VNC server and the fonts required. The Raspberry Pi already had the X11 fonts installed so I had to dig around on the internet to find out how to put them on.

Using

vncserver :1

It asks me to set up a password. Then with the windows Tightvnc viewer it connected perfectly.

So this is where I have got so far. The Tinker Board at the moment seems about as fast as a Pi 3, but I have not put it under any load yet. The operating system seems quite empty compared to Raspian. Then again it is a blank canvas. Following other Raspberry Pi tutorials I will try setting up some servers or even running Minecraft.

Leave a Reply

Your email address will not be published. Required fields are marked *

16 − nine =