Asus Tinker Board – Plex Media Server

I have been tinkering again with the tinker board.

This attempt using the Tinker OS 1.8 has been to see what I can get working on the board. Sadly it is still not a lot.

Webmin still works fine. TightVNC is now having problems if I don’t start it as soon as I start the box.

I decided to give Plex Media Server a go using these instructions from HTPC Guides. The instructions are long with numerous really useful methods for installing Plex.

I used this method.

 

sudo apt-get update && sudo apt-get install apt-transport-https binutils -y --force-yes

 

wget -O - https://dev2day.de/pms/dev2day-pms.gpg.key | sudo apt-key add -
echo "deb https://dev2day.de/pms/ jessie main" | sudo tee /etc/apt/sources.list.d/pms.list
sudo apt-get update
sudo apt-get install plexmediaserver -y

Everything looked fine on the install and then I attempted to log in via the web interface. This would be http://ip.address:32400/web (where ip.address is the address of your board.)

And it worked!!!

I could access the web interface and go through the set up. It looked awesome and it was ready and waiting for me to add media libraries.

I plugged in a portable hard drive with some files on but it did not want to access those. I expect that will be a permission problem.

However then it looked very promising until………

It tried to destroy my network. Typing into Putty became slow like the board was under a huge load. Except that wasn’t​ it. I could not reach any other websites internal or external. Not just me either. My wife could not surf anywhere on her phone and my son found his YouTube viewing reduced in quality.

As I could not set up WIFI from a headless ethernet connection I reverted to an older already configured image, verion 1.4 I think. I moved the board away from my router and followed the instructions again. It worked fine but I still had the permissions problem. I could see the files on the USB stick in the file manager on VNC session, I could play them on VLC but Plex would not see them.

Neither could I set up the board to browse my network to get any more files. This was one of the first things I could do with a Pi but just does not work on the Tinker Board.

I looked for an answer but the discussions I read about transcoding and under powered boards, I just kind of lost the will.

So in essence, Plex Media Server does work. The interface was smooth, I just could not get it to see my media to play it.

Leave a Reply

Your email address will not be published. Required fields are marked *

four × two =